Page tree

Overview

Starting with macOS 10.15 (one version after Mojave) 32-bit apps will not run. This version will be widely available starting fall 2019. Below is a list of apps known to be used in the district which will be affected.

If you require one or more of these apps please contact us by submitting a help a desk ticket. 

ApplicationVersionLast Updated
AbleNet Classroom Suite5.02016-10-17
LEGO MINDSTORMS Education EV31.4.32018-12-22
OverDrive Media Console1.2.02014-12-10
ShoreTel Communicator1.4.22016-08-22
XaoS3.52013-10-30

Need more help?

Need help? Submit a ticket to the help desk.

Create via email: Email WHD

Or, call extension 5100.